Viewing 4 reply threads
  • Author
    • #6291

      I am new to this product. I am hoping to eventually use this product for over 20,000 jpeg images that I have cataloged over the last 10 years. I started small with two folders each containing 50 jpeg images. I excluded all other image folders on my device(s). These 100 images all contain embedded tags (IPTC Keywords). In addition, 50 of the images are also “geo-tagged”. I am experiencing problems extracting the tags from the images. Of the 100 images, F-Stop only extracts tags from 15 images and indicates that the other 85 are “untagged”. If I use F-Stop to view the Details for any of the “untagged” images, data is displayed for the Keywords field. The location information for all 50 of the “geo-tagged” images properly displays on the F-Stop map. Image Date-Taken information appears to be correct on the F-Stop displays.

      I have tried my 100 image sample on a Samsung Galaxy Tab 2, Android 4.2.2, and Samsung Galaxy Tab S, Android 4.4.2. I used the same external SD card on both devices. The results were identical. The Pro version of F-Stop was installed on both devices.

      Any suggestions would be greatly appreciated. Thank you.

    • #6798
      Snide Snail

      I just see the tags in one image. The remaining 390 images are listed as untagged.

      Since I tagged most of them with MS Photo Gallery on the PC before copying to my Android device (Kobo tablet running 4.1.1) it’s a little disappointing. I’m running FStop, not Fstop pro like the previous poster. There’s no mention that you don’t get to see tags on the nonPro version.

      I’ve tried uninstalling and reinstalling but I still only get the tags out of one image.

      Any suggestions?

    • #6801
      Snide Snail

      In a moment of madness I bought the key because a friend said it worked with the key though not before. I loaded in 374 tagged images. I have an improvement on having the tags from only one image visible. I now can see tags from eleven different images. That is an improvement but not what I was hoping for. 363 images are listed as untagged.

      Again I ask… do you have any suggestions?

    • #6807

      I submitted my original support query over a year ago and received no responses. Essentially, I gave up on using the product because of the issues. In the interim, did some minimal investigation of this problem. Here is what I found:
      (1) My “jpeg” images are all tagged using the EXIF and IPTC tag sets.
      (2) It appears that F-Stop acquires most of its metadata from the XMP tag set. Although, it seems that the GPS location information may also be acquired from the EXIF tag values.
      (3) I noted that those images where F-Stop reported tag values were all values which had values in the XMP tags in addition to the same values in the EXIF and IPTC tag sets. For those images lacking values in the XMP tag sets no tag values were reported in F-Stop.
      (4) The obvious solution in my case would have been to implement a mechanism to propagate EXIF and IPTC tag set information to the XMP tag set. To date, I have been unwilling to undertake that effort.
      Hope this make some sense and explains what was initially a confusing situation.

    • #6808
      Snide Snail


      However I don’t think it’s that straightforward. All my images are tagged using Photo Gallery and the ones that appear with tags in are just some of the ones with the same tag. I can have tagged 20 photos with the same tag at the same time and only some of the tagged photos appear with tags. I can’t find a pattern. As far as I know Photo Gallery stores in the EXIF.

      Perhaps if I had some with XMP tags they would appear.

      GPS symbols are appearing on lots of the photos. I have not checked to see whether they are correct.

      I was assuming that it was something to do with memory usage or storage of a tag file or it’s device related, since as I said a friend uses it without problems.

      I’ve got no response from email either.

      • #6814
        Snide Snail

        Further to this I received an email reply from FStop which requested images and on sending images the following.

        “Thanks for sending the pictures. It looks like all these images do not have an XMP section for the tags but they do show in the properties section in Windows. When I add a tag then all of them are written to the file properly (using XMP). See attached. I am not sure how Windows Photo Gallery was writing them before but we only support XMP.”

        This confirms that FStop only reads XMP tags.

        On checking with Exiftool it appears that all the Windows Photo Gallery tags are in XMP. My problem was that because the original photos were 20MP images, I had used Faststone Resizer to reduce the size to something that I could fit comfortably on my tablet. Faststone helpfully moved the tags from XMP to EXIF. They are still in the file and show up in Photo Gallery before I copy them to the tablet but Exiftool shows that they are no longer in XMP format. Hence FStop can’t see them.

        So the real culprit was the resizing. Using Irfanview to resize the 400 odd tagged images kept the tags in XMP format and when transferred to the tablet FStop successfully recognised the tags.

        I apologise for my negative tone in earlier posts. FStop does appear to work as advertised as long as the tags are in XMP format and I did get a reply to an email from FStop support which helped me track the problem.

Viewing 4 reply threads
  • You must be logged in to reply to this topic.