Viewing 2 reply threads
  • Author
    Posts
    • #8492
      mknie
      Participant

      Screenshot:

      View post on imgur.com

      What you see in the screenshot is what happens everytime I try to create a new folder, it just makes these glitched versions with the * on the names, and I can’t even delete them, can’t rename them or remove the *, can’t move any images into it, I actually can’t do anything and can’t even delete them either so these black squares with the glitchy names just stay there

      This happens every single time I create a new folder, regardless of wether its within the internal storage or the sd card, even when I create it by choosing to move an image to a brand new folder its the same result and the image doesn’t get anywhere

      I’ve tried to create a new folder outside of the app entirely through “Files” and moved images inside, F-stop seemed to only show them briefly before the folder disappeared from the app altogether, even though its still visible in “Files”

      So I can’t create any new folders within the app because they glitch out like this, and even when I create them outside of the app they start to glitch out within the app

      It goes without saying that this is very inconvenient because there’s a couple new folders I need to make, some help would be appreciated

      • This topic was modified 1 year, 4 months ago by mknie.
    • #8494
      gorannagy
      Moderator

      Let me explain how folders in F-Stop work. First, F-Stop never deletes the actual folder. When you delete a folder it will only delete items in the folder and not actual folder. The reason for this is consistency, as if you have any file in the folder which is not shown by F-Stop (PDF for example), F-Stop won’t delete that file, and consequently it can’t delete the folder. So, it doesn’t delete folder even when it is empty, to have same behavior. That’s why you can’t delete created folder. We may however change this, so that when folder is empty, it will get deleted.

      As for those those ** folders. In “Folders view” F-Stop shows only folders with images. So, when you create a new folder it will be empty, and F-Stop would not show it. So, it makes an exception to the rule here and it will show those folders as first items but ads ** characters so that it is visible these folders are newly created and empty. When you restart F-Stop, these folders will not be visible any more. It’s by design. When you try to copy files, this folder should still be visible and you can select it, so you can actually move/copy files to it.

      • This reply was modified 1 year, 4 months ago by gorannagy.
    • #8497
      mknie
      Participant

      Hi, I managed to find a workaround through the files app to create those folders, but I thought it’d be worth mentioning that restarting the app didn’t actually make these empty * go away, and trying to move or copy files into it also wasn’t working, I managed to get them away after lots of trial and error but I can’t exactly say for sure what made it work or not, but restarting the app wasn’t cutting it.

      I have the folders I needed now so its all good, but I thought that’d be worth mentioning, it might potentially be an issue with my device or my sd card, I’m really not sure, but regardless I’m really satisfied with the app outside of a few minor hiccups, its fantastic.

Viewing 2 reply threads
  • You must be logged in to reply to this topic.