From Google Play.. Installed ver 4.6.3 few weeks back, upgraded to pro thru G Play, no probs. Running Android 6.0 w/security patch 7-1-2016 update. Bone stock setup, nothing too special on it. All my pics reside on sd card, a couple of gigs worth for testing for now. No probs with folders, etc thru F Stop or TCmdr as my goto file app on the stylo. Version of the stylo is the 2gig mem. I’m an IT consultant and old guy, so not much clutter on it.

Only got onto this prob last night while playing around. Constantly play around with diff things to try to get it to revert back, like changing opening display, etc, etc. Pics are in abt 10 subdir’s off one folder on root of sd card (BPics).. no spaces in names.. Everything else (that I’ve tried) works as I’ve worked thru the tutorials. Added and deleted 4 or 5 subdirs now since this started.. doesn’t affect it.

Only thing else was one photo subdir that stopped showing abt a 100 jpgs.. just one (first one) listed.. but files were there under TC. Some had capitalized ‘.JPG’ so I just fixed that on my PC set and deleted, the subdir, reloaded it from PC. Didn’t really look deep abt it at all. That was well before the grid prob showed up. I don’t see a connection, but just FYI. Hard to believe THAT made any diff. Still coming up to speed with experimenting with all the pro stuff in it to organize.. So impressive in it’s layers of abilities and versatility to allow me to do custom presentations without changing my basic folder (old school??) storage system…lol..

email me if you want me to try things but not load up your forum.. Thanks for quick reply!

Bob Crash